Tue, 19 Sep 2017 14:14:32 -0400JNI-3 more option disabled in gpg because unused in pEp. JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Tue, 19 Sep 2017 14:14:32 -0400] rev 376
JNI-3 more option disabled in gpg because unused in pEp.

Tue, 19 Sep 2017 14:13:08 -0400JNI-3 avoid continuous "NOTE: THIS IS A DEVELOPMENT VERSION!" claims in gpg's stderr. JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Tue, 19 Sep 2017 14:13:08 -0400] rev 375
JNI-3 avoid continuous "NOTE: THIS IS A DEVELOPMENT VERSION!" claims in gpg's stderr.

Fri, 15 Sep 2017 12:01:10 -0400fixed encrypt/decrypt test (subject isn't "pEp" anymore) JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Fri, 15 Sep 2017 12:01:10 -0400] rev 374
fixed encrypt/decrypt test (subject isn't "pEp" anymore)

Fri, 15 Sep 2017 11:57:54 -0400JNI-3 fixed gpgme having hickups swallowing gpg's output on 32b platforms. JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Fri, 15 Sep 2017 11:57:54 -0400] rev 373
JNI-3 fixed gpgme having hickups swallowing gpg's output on 32b platforms.

Wed, 13 Sep 2017 23:42:00 -0400JNI-3 gpgme still use old libtool, not android aware. Fix doesn't help with current bugs, but nice try... JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Wed, 13 Sep 2017 23:42:00 -0400] rev 372
JNI-3 gpgme still use old libtool, not android aware. Fix doesn't help with current bugs, but nice try...

Wed, 13 Sep 2017 10:14:53 -0400JNI-3 more bin bloat (why does uuid install produce those *INST* files in some arch ?) JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Wed, 13 Sep 2017 10:14:53 -0400] rev 371
JNI-3 more bin bloat (why does uuid install produce those *INST* files in some arch ?)

Wed, 13 Sep 2017 09:00:36 -0400JNI-3 binary bloat cleanup, first step JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Wed, 13 Sep 2017 09:00:36 -0400] rev 370
JNI-3 binary bloat cleanup, first step

Tue, 12 Sep 2017 21:00:21 -0400JNI-3 fix executables linking failing on arm64-v8a. Why is linking to liblog.so failing despite of liblog being in sysroot ? Why only on that arch ? Anyhow, -llog was useless here. "Fixed" JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Tue, 12 Sep 2017 21:00:21 -0400] rev 369
JNI-3 fix executables linking failing on arm64-v8a. Why is linking to liblog.so failing despite of liblog being in sysroot ? Why only on that arch ? Anyhow, -llog was useless here. "Fixed"

Tue, 12 Sep 2017 17:43:58 -0400JNI-3 CMake's EXEc linker flags for gpg, SHARED for the rest. (otherwise gpgme can't load gpg on platform where linker requires PIE, as x86_64) JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Tue, 12 Sep 2017 17:43:58 -0400] rev 368
JNI-3 CMake's EXEc linker flags for gpg, SHARED for the rest. (otherwise gpgme can't load gpg on platform where linker requires PIE, as x86_64)

Tue, 12 Sep 2017 17:41:24 -0400JNI-3 update latest gradle plugin JNI-3 JNI-4 JNI-39 JNI-40 JNI-41
Edouard Tisserant <edouard@pep-project.org> [Tue, 12 Sep 2017 17:41:24 -0400] rev 367
JNI-3 update latest gradle plugin