'install_headers' depends on the header files having been generated, this dependency was not specified in the makefile. sync
authorDamiano Boppart <damiano.boppart@pep.security>
Wed, 04 Sep 2019 13:58:59 +0200
branchsync
changeset 4043f01fbfb593b3
parent 4041 276b75a00083
child 4048 1b987bcd8efe
child 4050 6608abc1ce8c
'install_headers' depends on the header files having been generated, this dependency was not specified in the makefile.

Maybe the dependency '$(TARGET)' is too "broad", and it would be more exact to just depend on the stuff the makefiles do in /asn.1 ...
src/Makefile
     1.1 --- a/src/Makefile	Sat Aug 31 15:40:25 2019 +0200
     1.2 +++ b/src/Makefile	Wed Sep 04 13:58:59 2019 +0200
     1.3 @@ -105,7 +105,7 @@
     1.4  # CAVEAT:
     1.5  # install_headers is needed for building pEp MIME
     1.6  
     1.7 -install_headers:
     1.8 +install_headers: $(TARGET)
     1.9  	mkdir -p $(PREFIX)/include/pEp
    1.10  	cp pEpEngine.h keymanagement.h message_api.h dynamic_api.h stringlist.h \
    1.11  	   timestamp.h identity_list.h bloblist.h stringpair.h message.h mime.h \