fixed compatibility issue with gpgme-1.6.0, in a way compatible with later versions
authorEdouard Tisserant <edouard@pep-project.org>
Wed, 23 Nov 2016 11:45:32 +0100
changeset 1421eab02fe87a52
parent 1420 aa362751c2b3
child 1422 860391e5e5b9
fixed compatibility issue with gpgme-1.6.0, in a way compatible with later versions
src/pgp_gpg.c
     1.1 --- a/src/pgp_gpg.c	Wed Nov 23 11:30:48 2016 +0100
     1.2 +++ b/src/pgp_gpg.c	Wed Nov 23 11:45:32 2016 +0100
     1.3 @@ -429,7 +429,7 @@
     1.4  
     1.5      dt = gpg.gpgme_data_identify(cipher);
     1.6      switch (dt) {
     1.7 -#ifdef GPGME_DATA_TYPE_PGP_ENCRYPTED 
     1.8 +#if GPGME_VERSION_NUMBER > 0x010600
     1.9      case GPGME_DATA_TYPE_PGP_ENCRYPTED:
    1.10  #endif
    1.11      case GPGME_DATA_TYPE_PGP_SIGNED: