fixed compatibility issue with gpgme-1.6.0
authorEdouard Tisserant <edouard@pep-project.org>
Wed, 23 Nov 2016 11:30:48 +0100
changeset 1420aa362751c2b3
parent 1419 54d8198b2cdf
child 1421 eab02fe87a52
fixed compatibility issue with gpgme-1.6.0
src/pgp_gpg.c
     1.1 --- a/src/pgp_gpg.c	Wed Nov 23 00:52:29 2016 +0100
     1.2 +++ b/src/pgp_gpg.c	Wed Nov 23 11:30:48 2016 +0100
     1.3 @@ -429,7 +429,9 @@
     1.4  
     1.5      dt = gpg.gpgme_data_identify(cipher);
     1.6      switch (dt) {
     1.7 +#ifdef GPGME_DATA_TYPE_PGP_ENCRYPTED 
     1.8      case GPGME_DATA_TYPE_PGP_ENCRYPTED:
     1.9 +#endif
    1.10      case GPGME_DATA_TYPE_PGP_SIGNED:
    1.11      case GPGME_DATA_TYPE_PGP_OTHER:
    1.12          gpgme_error = gpg.gpgme_op_decrypt_verify(session->ctx, cipher,