ENGINE-128: merged in key expiry bug fix from default. ENGINE-128
authorKrista Grothoff <krista@pep-project.org>
Mon, 24 Oct 2016 14:39:03 +0200
branchENGINE-128
changeset 13270b48955f6d74
parent 1325 5f2e643a4fd7
parent 1326 3d97f4c0ee25
child 1328 b8163caba309
ENGINE-128: merged in key expiry bug fix from default.
     1.1 --- a/src/pgp_gpg.c	Mon Oct 24 14:35:42 2016 +0200
     1.2 +++ b/src/pgp_gpg.c	Mon Oct 24 14:39:03 2016 +0200
     1.3 @@ -2012,7 +2012,8 @@
     1.4          bool sgn_available = false;
     1.5          bool enc_available = false;
     1.6          for (_sk = key->subkeys; _sk; _sk = _sk->next) {
     1.7 -            if (_sk->expires > when) // not expired at that date ?
     1.8 +            if (_sk->expires > when || _sk->expires == 0) // not expired at that date ?
     1.9 +                                                          // Also, zero means "does not expire"
    1.10              {
    1.11                  if (_sk->can_certify) crt_available = true;
    1.12                  if (_sk->can_sign) sgn_available = true;