Document findings on asn1c versions regarding 'alloca' POSIX compat. ENGINE-228
authorDamiano Boppart <damiano@pep-security.net>
Wed, 16 Aug 2017 15:37:02 +0000
branchENGINE-228
changeset 1967027b3e3febae
parent 1966 0329556f28ab
child 1968 e30b1515b7b9
Document findings on asn1c versions regarding 'alloca' POSIX compat.
README.txt
     1.1 --- a/README.txt	Wed Aug 16 15:27:54 2017 +0000
     1.2 +++ b/README.txt	Wed Aug 16 15:37:02 2017 +0000
     1.3 @@ -60,8 +60,7 @@
     1.4  
     1.5  * NetPGP/p≡p, see https://cacert.pep.foundation/dev/repos/netpgp-et/
     1.6  
     1.7 -* Asn1c, download from https://lionet.info/soft/asn1c-0.9.27.tar.gz
     1.8 -       (Debian's version 0.9.24 does not work)
     1.9 +* Asn1c, download from https://lionet.info/soft/asn1c-0.9.27.tar.gz . Debian 8's v0.9.24 does not work. Debian 9's v0.9.27 generates non-POSIX code, that will cause issues when the engine is compiled with '-std=c99'. Thus, use v0.9.28 for best results.
    1.10  
    1.11  * yml2, which needs lxml (where to get?)
    1.12