Thu, 10 Aug 2017 18:44:57 +0200Close ENGINE-226 ENGINE-226
Edouard Tisserant <edouard@pep-project.org> [Thu, 10 Aug 2017 18:44:57 +0200] rev 1947
Close ENGINE-226

Wed, 09 Aug 2017 15:22:21 +0200ENGINE-226 pEpEngine.h doc update for user_id ENGINE-226
Edouard Tisserant <edouard@pep-project.org> [Wed, 09 Aug 2017 15:22:21 +0200] rev 1946
ENGINE-226 pEpEngine.h doc update for user_id

Wed, 09 Aug 2017 14:23:23 +0200ENGINE-226 identity->me => _identity_me() ENGINE-226
Edouard Tisserant <edouard@pep-project.org> [Wed, 09 Aug 2017 14:23:23 +0200] rev 1945
ENGINE-226 identity->me => _identity_me()

Tue, 08 Aug 2017 15:00:18 +0200Merged default in test_diphoton test_diphoton
Edouard Tisserant <edouard@pep-project.org> [Tue, 08 Aug 2017 15:00:18 +0200] rev 1944
Merged default in test_diphoton

Mon, 07 Aug 2017 16:42:49 +0200ENGINE-225 re_evaluate_message_rating() should stop complaining about illegal value if feeded with an unencrypted message already having X-EncStatus optfield
Edouard Tisserant <edouard@pep-project.org> [Mon, 07 Aug 2017 16:42:49 +0200] rev 1943
ENGINE-225 re_evaluate_message_rating() should stop complaining about illegal value if feeded with an unencrypted message already having X-EncStatus optfield

Thu, 03 Aug 2017 16:00:49 +0200Use ETPAN_IN on Linux, and suggest it be set in Makefile.conf
Damiano Boppart <damiano@pep-security.net> [Thu, 03 Aug 2017 16:00:49 +0200] rev 1942
Use ETPAN_IN on Linux, and suggest it be set in Makefile.conf

Tue, 25 Jul 2017 13:51:42 +0200backport 2.0.30 compatible ggp-agent killing methods from gpgme_passphrase_cb's branch test
Edouard Tisserant <edouard@pep-project.org> [Tue, 25 Jul 2017 13:51:42 +0200] rev 1941
backport 2.0.30 compatible ggp-agent killing methods from gpgme_passphrase_cb's branch test

Mon, 24 Jul 2017 09:56:31 -0400ENGINE-220 passphrase_cb confirmed working with 2.1.18 and 1.8.0 (current from debian stable). Experimental code NOT TO BE MERGED ! gpgme_passphrase_cb
Edouard Tisserant <edouard@pep-project.org> [Mon, 24 Jul 2017 09:56:31 -0400] rev 1940
ENGINE-220 passphrase_cb confirmed working with 2.1.18 and 1.8.0 (current from debian stable). Experimental code NOT TO BE MERGED !

Mon, 24 Jul 2017 15:29:32 +0200ENGINE-220 no way to use passphrase_cb with 2.0.30. Simply never get called in case of passphras protected key, pinentry dialog keeps showing up. Moving to 2.1 see if anything better gpgme_passphrase_cb
Edouard Tisserant <edouard@pep-project.org> [Mon, 24 Jul 2017 15:29:32 +0200] rev 1939
ENGINE-220 no way to use passphrase_cb with 2.0.30. Simply never get called in case of passphras protected key, pinentry dialog keeps showing up. Moving to 2.1 see if anything better

Sat, 22 Jul 2017 00:06:09 +0200ENGINE-220 empirical nullshit trying to have gpg behave when passphrase callback is set with gpg 2.0.x gpgme_passphrase_cb
Edouard Tisserant <edouard@pep-project.org> [Sat, 22 Jul 2017 00:06:09 +0200] rev 1938
ENGINE-220 empirical nullshit trying to have gpg behave when passphrase callback is set with gpg 2.0.x